Aici veti gasi detalii tehnice despre cum se pot realiza configurari software+ hardware.
Here you can find tehnical details about software/hardware configuration.

sâmbătă, 18 august 2012

CentOS Auto Login

If you want to login automatically with a specific user simply edit /etc/gdm/custom.conf to add the following two lines in the [daemon] section: [daemon] AutomaticLoginEnable=true AutomaticLogin=username

joi, 9 august 2012

Installing Xfce4 in FreeBSD with auto login

Installing X11

Xorg is the default X11 implementation for FreeBSD and can be installed using the following command as the root user

1# pkg_add -r xorg
After installing add the lines to /etc/rc.conf as follows
1moused_enable=”YES”
2dbus_enable=”YES”
3hald_enable=”YES”
Check the installation using the following command as an unprivileged user
1$ xinit
If the setup is working, there should be a minimal X session running. Press CTRL+ALT+F1 to move to the first terminal in which the command was executed. Press CTRL+C to stop it.
To create a xorg.conf.new file run the following command as the root user. Reboot the server after installing Xorg if the following command doesn’t work.
1# Xorg -configure
A file named xorg.conf.new will be created in /root. To check the file created run the following command as root
1# Xorg -config /root/xorg.conf.new -retro
If the configuration is working properly, a background with mouse cursor is seen. Press CTRL+ALT+F1 to move to the first terminal in which the command was executed. Press CTRL+C to stop it.
Copy the file to  /etc/X11/ as xorg.conf as the root user using the following command
1# cp /root/xorg.conf.new /etc/X11/xorg.conf
Installing URW fonts
URW fonts can be installed by using the command
1# pkg_add -r  urwfonts
Add the following line to the file /etc/X11/xorg.conf under ‘Section “Files”‘
1FontPath "/usr/local/lib/X11/fonts/URW/"

Installing TTF fonts

TTF fonts can be installed by using the following command
1# pkg_add -r ttmkfdir
Check whether the following line is present under ‘Section “Files”‘ in /etc/X11/xorg.conf
Add the following line to the ‘Section “Modules”‘
1Load  "freetype"
Enter the following commands now
1# cd /usr/local/lib/X11/fonts/TTF/
2# ttmkfdir -o fonts.dir

Installing Xfce4

For installing Xfce4 run the following command as root
1# pkg_add -r xfce4
The Xfce4 installation can be checked using the following command as an unprivileged user
1$ /usr/local/bin/startxfce4
Install XDM using the following command
1# pkg_add -r xdm
Run the following command as the unprivileged user to make xfce the default for the particular user
1$ echo "/usr/local/bin/gnome-session" >> ~/.xsession
2$ echo "/usr/local/bin/gnome-session" >> ~/.xinitrc
Add the following line to /etc/rc.conf
1xdm_enable="YES"
Edit the file /etc/ttys and edit the line as follows
1ttyv8   "/usr/local/bin/xdm -nodaemon"  xterm   on  secure
Now reboot the machine to boot into XDM and try logging in. It will login to Xfce.

In this case after login you can take the "startx" command in console and Xfce will start.

==============================================

If you wish to login xfce after boot with a specific user you can use the folowing procedure:

There are 3 files you need to edit:
1. /etc/gettytab
2. /etc/ttys
3. Your shells' rc file, e.g: ~/.bashrc

Edit /etc/gettytab and search for autologin. Add these after the last entries:


Code:
logmein:\
        :al=your_username:sp#115200:
Replace 'your_username' with your user login.

Next edit /etc/ttys. I set mine to autologin on ttyv5. So my entry looks like this:

Code:
#ttyv5  "/usr/libexec/getty Pc"         cons25  on  secure
ttyv5   "/usr/libexec/getty logmein"    cons25  on  secure
Lastly, I'm using bash shell so this is what I have in my ~/.bashrc:

Code:
if [ `/usr/bin/tty` = '/dev/ttyv5' ]; then
    /usr/bin/ssh-agent /usr/local/bin/startx -- -nolisten tcp
fi
Hope this helps.


source
source

duminică, 5 august 2012

Conexiune la Internet cu Asus WL500G si ZTE MF110

Se conecteaza modemul la un PC si cu ajutorul aplicatiei JoinAir, dezactivam PIN-ul  si optiunea ZeroCD.
Se conecteaza modemul in portul USB al routerului si se verifica in fereastra Status&Log | Diagnostic Info, urmatoarele informatii:
USB Devices
T: Bus=01 Lev=00 Prnt=00 Port=00 Cnt=00 Dev#= 1 Spd=12 MxCh= 2
B: Alloc= 0/900 us ( 0%), #Int= 0, #Iso= 0
D: Ver= 1.10 Cls=09(hub ) Sub=00 Prot=00 MxPS= 8 #Cfgs= 1
P: Vendor=0000 ProdID=0000 Rev= 0.00
S: Product=USB OHCI Root Hub
S: SerialNumber=b8004000
C:* #Ifs= 1 Cfg#= 1 Atr=40 MxPwr= 0mA
I: If#= 0 Alt= 0 #EPs= 1 Cls=09(hub ) Sub=00 Prot=00 Driver=hub
E: Ad=81(I) Atr=03(Int.) MxPS= 2 Ivl=255ms
T: Bus=01 Lev=01 Prnt=01 Port=00 Cnt=01 Dev#= 2 Spd=12 MxCh= 0
D: Ver= 2.00 Cls=00(>ifc ) Sub=00 Prot=00 MxPS=64 #Cfgs= 1
P: Vendor=19d2 ProdID=0016 Rev= 0.00
S: Manufacturer=ZTE,Incorporated
S: Product=ZTE WCDMA Technologies MSM
S: SerialNumber=P671A2ZTED010000
C:* #Ifs= 4 Cfg#= 1 Atr=e0 MxPwr=500mA
I: If#= 0 Alt= 0 #EPs= 2 Cls=ff(vend.) Sub=ff Prot=ff Driver=serial
E: Ad=81(I) Atr=02(Bulk) MxPS= 64 Ivl=0ms
E: Ad=01(O) Atr=02(Bulk) MxPS= 64 Ivl=0ms
I: If#= 1 Alt= 0 #EPs= 2 Cls=ff(vend.) Sub=ff Prot=ff Driver=serial
E: Ad=82(I) Atr=02(Bulk) MxPS= 64 Ivl=0ms
E: Ad=02(O) Atr=02(Bulk) MxPS= 64 Ivl=0ms
I: If#= 2 Alt= 0 #EPs= 3 Cls=ff(vend.) Sub=ff Prot=ff Driver=serial
E: Ad=83(I) Atr=03(Int.) MxPS= 64 Ivl=5ms
E: Ad=84(I) Atr=02(Bulk) MxPS= 64 Ivl=0ms
E: Ad=03(O) Atr=02(Bulk) MxPS= 64 Ivl=0ms
I: If#= 3 Alt= 0 #EPs= 2 Cls=08(stor.) Sub=06 Prot=50 Driver=usb-storage
E: Ad=04(O) Atr=02(Bulk) MxPS= 64 Ivl=0ms
E: Ad=85(I) Atr=02(Bulk) MxPS= 64 Ivl=0ms
USB devfs Devices
Device : Location : Info
/dev/usb/tts/0 : 1.0 : Manufacturer=”ZTE,Incorporated” : Product=”ZTE WCDMA Technologies MSM”
/dev/usb/tts/1 : 1.1 : Manufacturer=”ZTE,Incorporated” : Product=”ZTE WCDMA Technologies MSM”
/dev/usb/tts/2 : 1.2 : Manufacturer=”ZTE,Incorporated” : Product=”ZTE WCDMA Technologies MSM”
Se observa informatiile pentru ProductID, VendorID si locatia pe care a fost detectat modemul (USB devfs Devices | ! Daca aici nu apare nimic inseamna ca nu a reusit dezactivarea optiunii ZeroCd din aplicatia JoinAir si se va face acest lucru prin executarea comenzii AT+ZCDRUN=8).
Mai departe configuram conexiunea. Setarile care trebuiesc efectuate pe router sunt:
In fereastra USB Connection | Connection Mode
- Enable automatic dial on boot | Yes
- Use WAN port as LAN | No
- Disable USB 2.0 controller | No
- Mod conectare | GPRS/EDGE/UMTS
In fereastra USB Connection | GPRS/EDGE/UMTS Config
Username: user
Password: user
APN: internet (sau APN-ul furnizorului, daca difera)
Dial Number (usually *99***1#): *99#
USB device serial speed (usually 115200): 115200
USB device location ID: 1.2 (este posibil sa fie diferit, in functie de modelul de router folosit si de portul pe care a fost conectat modemul)
USB device Vendor ID (0xabcd): 0x19d2
USB device Product ID (0xefgh): 0×0016
USB device packet size (0 for default): 0
Modem type: Not set
Toate celelalte setari se lasa neschimbate. Se da click pe Apply | Finish | Save & Restart. Dupa restart routerul se va conecta la internet automat.
Implicit, routerul va folosi modemul ca si modalitate principala de conectare la internet. Este posibil sa fie setat si ca backup, caz in care se fac setarile corespunzatoare in fereastra Backup Connection.

source


Pentru situatiile in care este necesara executarea comenzilor AT pe modemurile 3G printr-o conexiune seriala, se poate utiliza programul HyperTerminal (Windows), Putty (Windows, Linux) sau Terminal (MAC).
Pentru asta, este necesar sa stim portul utilizat de modem (Windows: Device Manager | Modems | nume_modem | Properties | Modem, Linux: ALT+CTRL+F1 > dmesg | grep tty MAC: System Preferences | Network | Internal Modem).
Pentru a ne asigura ca portul modemului nu este utilizat, se inchide orice aplicatie care comunica cu modemul (JoinAir, VMC etc.); eventual se deconecteaza orice disk drive detectat de catre sistem (cu Safely Remove Hardware, Unmount etc.). Daca modemul a fost conectat la internet, este mai bine sa-l deconectati/reconectati din portul USB si sa va asigurati ca nu mai este lansata nicio aplicatie.
Se creeaza o conexiune seriala pe portul modemului utilizand una din aplicatiile enumerate mai sus  si se conecteaza.
De exemplu, in cazul modemului ZTE MF110, pentru a verifica conexiunea puteti trimite comanda ATI care va returna informatiile despre dispozitivul conectat.
Pentru a dezactiva optiunea ZEROCD, rulati comanda AT+ZCDRUN=8. In cazul in care ulterior doriti reactivarea ZEROCD, rulati comanda AT+ZCDRUN=9.
Rezultatul se poate vedea mai jos.


+ZPSTM: 1,4368616E676520494D5349;1,4368616E676520494D5349;
+ZEND
ATI
Manufacturer: ZTE CORPORATION
Model: MF110
Revision: BD_P671A2V1.0.1B04
IMEI: 351790039268926
+GCAP: +CGSM,+DS,+ES
OK
AT+ZCDRUN=8
Close autorun state result(0:FAIL 1:SUCCESS):1
OK

  source

Map


Visitor Map